FreeBSD uses ports to install and upgrade software. Ports collection can be found at /usr/ports/, if its not installed, you can always install it with /stand/sysinstall utility.
Upgrading ports
# cd /usr/ports/sysutils/portupgrade
# make all install
# cd /usr/ports/sysutils/portsnap
# make all install
# cd /usr/local/etc
# mv portsnap.conf.sample portsnap.conf
# cd /usr/local/sbin
# ./portsnap fetch
# ./portsnap extract
The above commands will install two programs, portupgrade, and portsnap. These programs update the installed applications and uninstalled sources, respectively. These two programs work together in keeping FreeBSD up to date.
In order to apply the updated patch sets, execute the below:
# /usr/local/sbin/portsnap fetch
# /usr/local/sbin/portsnap update
In order to upgrade the installed applications, execute:
# /usr/local/sbin/portupgrade –a